toolkit工具

为了方便开发,提供了hap-toolkit来帮助开发者通过命令行工具来完成工程的创建等工作

安装NodeJS

需安装6.0以上版本的NodeJS,请从NodeJS官网下载

安装工具

通过npm仓库安装,在命令行中执行以下命令:

npm install -g hap-toolkit

在命令行中执行hap -V会输出版本信息表示hap-toolkit安装成功,如下命令所示:

hap -V

创建新工程

用来创建一个模板工程项目

hap init <ProjectName>

进入工程的根目录运行如下命令安装依赖包

npm install

升级工程

用来进行常规工程目录结构与依赖的升级

进入已经建好的工程目录中

hap update

命令参数:

--force 强制升级(将当前工程升级到hap-toolkit版本, 有可能导致版本降级,请谨慎使用)

升级完成后,在工程目录中运行npm install安装依赖库

命令帮助

hap --help

工具更新

重新全局安装工具即可,请参考上面安装工具

条匹配 "" 的结果

    没有搜索到与 "" 相关的内容